We support Internet Explorer 11, Edge, and generally any recent versions of all other browsers. If you're experiencing an issue and feel you're using a supported browser let us know. We'd be happy to help you straighten it out.